当前位置:首页 >文艺新风 > 正文

布香件的 蓝断事点网阿里港R云发用区务中C服n可说明

2026-10-04 04:44:44文艺新风
对冷塔、阿里解锁群控逻辑启动4台冷机耗时3小时32分钟。云发用区工程师对这个包间的布香服务器进行了仔细的数据安全检查,NAT有分钟级业务受损。中网包间温度逐渐升高,断事加强阿里云管控平面的说明容灾演练,

改进措施:全网巡检,蓝点RDS等更多云服务  。阿里可用性最低跌至20%。云发用区

服务影响

12月18日09:23  ,布香

改进措施:提升故障影响和客户影响的中网快速评估和识别拉取能力 。其中 ,断事阿里云香港Region可用区C发生大规模服务中断事件。说明对于业务需要绝对高可用的蓝点客户,提高信息发布的阿里速度,新扩容的ECS管控系统启动时依赖的中间件服务部署在可用区C机房 ,我们提供了克隆实例 、但系统仍然无法保持稳定运行 。12:45完成SLB等大部分网络产品可用区容灾逃逸,

阿里云

2022年12月25日

部分实例的迁移恢复过程遇到一些异常情况 ,明确温升场景下的业务侧关机和机房强制关电的预案,一种是OSS本地冗余LRS服务(通常叫单AZ冗余服务) ,扩大覆盖度 ,

总结

最后 ,期间,由于依赖单可用区的数据备份,22:50,19:47,没有直接影响客户在香港其他可用区运行的业务 ,我们持续建议您采用全链路多可用区的业务架构设计 ,这部分OSS服务(单AZ冗余服务)才恢复了对外服务能力。

自10:30开始,其中一个包间因消防喷淋启动 ,并尽快处理赔偿事宜。因大量可用区C的客户在香港其他可用区新购ECS实例 ,RDS MySQL与Redis 、但影响了香港Region ECS管控服务(Control Plane)的正常使用。出现服务异常的实例数量随之增加,但均不能保持稳定运行 。导致客户新购实例后出现启动失败的现象  。无法通过代理地址访问RDS实例。从11:07至18:26中断了服务 。工程师对服务器进行停机操作,除上述少量单可用区产品以外,陆续启动冷机  ,随着机房制冷设备恢复 ,Privatelink以及少量GA实例)在此次故障中受到影响  。

12月18日10:17开始 ,在这次事件中依然可以维持业务运行。通知机房服务商进行现场排查 。实例迁移等临时性恢复方案 ,影响水路循环导致4台主冷机服务异常 ,经冷机设备商工程师现场手工调整配置  ,DTS等大部分跨可用区实例完成跨可用区切换 。受影响的服务器停机数量持续增加 ,阿里云香港可用区C的部分存储服务OSS开始受到停机影响 ,并通过常态化演练强化执行。冷却水管路及冷机冷凝器进行手工补水排气操作 ,但由于底层服务资源的限制,此时 ,15:20,18:55,确保系统自动切换逻辑符合预期,阿里云工程师开始进行服务启动恢复 ,有效信息不够。启动制冷异常应急预案,由于代理服务不可用 ,阿里云工程师对部分高温包间启动服务器关机操作。部分服务器开始受到影响。

以下内容转自阿里云官方,OSS 、阿里云本着负责任的态度公布了这次中断事件的完整报告,4台冷机恢复到正常制冷量。故障信息发布不够及时透明

原因分析 :故障发生后阿里云启动对客钉群、进行辅助散热和应急通风。ECS管控服务触发限流,花费了较多的时间进行完整性检验工作 。恢复服务前,但持续高温会导致磁盘坏道,导致较长时间内无法扩容。大数据集群进行降载处理。防止内部状态死锁从而影响故障的恢复。阿里云在香港Region可用区C提供了2种类型的OSS服务 ,我们协助相关客户通过临时切换到使用RDS主实例的地址访问来进行恢复 。此时客户暂不会感知,公告等通知手段,原因定位耗时3小时34分钟 ,对我们的客户至关重要。数据检查以及风险评估完成 ,同时可用区C的ECS实例拉起恢复动作引入的流量,API完全恢复可用为当日23:11。继续多次对冷机设备进行操作,尽快上线新版的阿里云服务健康状态页面(Status Page),

4 、让客户可以更便捷地了解故障事件对各类产品服务的影响 。数据库 、阿里云监控到香港Region可用区C机房包间通道温控告警,k8s用户控制台操作也受到了故障影响。可用区C的OSS本地冗余服务中断时间较长,

3.客户在香港地域新购ECS等管控操作失败

原因分析:ECS管控系统为B 、冷水机组无法恢复正常  。ECS管控依赖的自定义镜像数据服务 ,大部分机房包间服务器陆续启动并完成检查,因机房冷却系统的群控逻辑 ,力求更简单有效,依照故障处理流程,由于自定义镜像数据服务依赖可用区C的单AZ冗余版本的OSS服务,但发现无法稳定运行,21:30左右绝大部分数据库实例恢复正常 。在多方工程师诊断下 ,并持续观察温升情况。整个过程中,此时,冷机设备供应商对设备问题排查遇到困难 ,第1台冷机恢复正常,以应对各种可能的意外事件 。部分机器硬件损坏 ,C可用区双机房容灾 ,部分实例在购买成功之后会出现启动失败的现象 ,最后一个包间依据安全性逐步进行供电恢复和服务器启动。我们要向所有受到故障影响的客户公开致歉,部分单可用区实例以及单可用区高可用实例 ,单AZ本地冗余LRS服务有部分服务器因消防问题需要做隔离处理 。联系冷机设备供应商到现场排查 。直至12月19日00:30 ,从18:26开始,因为保持数据的完整性至关重要,

改进措施 :加强机房服务商管理 ,OSS同城冗余ZRS服务基本没有受到影响 。需要花费较长的时间来处理解决。C和D。我们必须要确保数据可靠性,

处理过程

12月18日08:56 ,09:17,香港Region可用区C部分ECS服务器开始出现停机,我们将尽一切努力从此次事件中吸取经验教训,工程师启动数据库应急切换预案流程。为避免可能出现的高温消防问题,对于受故障影响的单机版实例及主备均在香港Region可用区C的高可用版实例 ,客户在使用RunInstances/CreateInstance API购买新ECS实例时 ,冷机系统故障恢复时间过长

原因分析 :机房冷却系统缺水进气形成气阻 ,经过复盘,少量支持跨可用区切换的RDS实例没有及时完成切换 。触发同可用区内宕机迁移。阿里云工程师陆续对整个机房计算 、经排查是由于这部分RDS实例依赖了部署在香港Region可用区C的代理服务  ,14:47 ,需要依赖故障机房的恢复 。整体优化多AZ产品高可用设计 ,同时  ,稳定性是云服务的生命线,阿里云监控到该机房多个包间温升告警 ,19:02 ,温度开始下降。梳理机房温升预案及标准化执行动作 ,阿里云工程师介入应急处理 ,存储服务器重新分批启动 。其中一个包间因高温触发了强制消防喷淋。并进行必要的数据完整性检查 。09:09,仅少量实例实现有效迁移 。随着温度继续升高,阿里云香港Region可用区C部分RDS实例出现不可用的报警。欲了解更多产品请访问阿里云官网:https://ourl.co/aliho


北京时间2022年12月18日 ,影响面扩大到香港可用区C的EBS、从12月18日14:49开始,问题分析和改进措施。13:47NAT产品完成收尾逃逸。增加了后续恢复难度和时长。

阿里云香港可用区C的故障,机房温度趋于稳定。网络、无法通过重试解决。MongoDB 、冷机群控解锁完成并独立运行,依赖可用区C的单AZ冗余版本的OSS服务 ,电源柜和多列机柜进水,

21:36,

我们注意到 ,Status Page页面信息更新不及时引发客户困惑  。因不支持跨可用区切换 ,未进行服务器上电。由于大量可用区C的客户在香港其他可用区新购实例 ,

12月18日10:37,在此次故障中,

问题分析与改进措施

1 、C可用区故障后由B可用区对外提供服务,对很多客户的业务产生重大影响 ,提升精细度 ,持续提升云服务的稳定性,我们在这里向大家进一步说明故障情况、由于高温原因 ,分批启动服务器 ,机房温度稳定。提高对故障的排查和定位速度;在设施管控逻辑层面,现场处置不及时导致触发消防喷淋

原因分析 :随着机房冷却系统失效,影响数据安全,机房服务商按应急预案对异常冷机进行4+4主备切换以及重启  ,冷机设备供应商到场 ,导致可用区 B 管控服务资源不足。尝试对冷机控制系统逐个进行隔离和手工恢复操作,09:01,

2 、仅部署在可用区C;另一种是OSS同城冗余ZRS服务(通常叫3AZ冗余服务),工程师启动网络产品可用区容灾逃逸 ,这里花费了一些必要的时间。也是阿里云运营十多年来持续时间最长的一次大规模故障。同时在多个可用区运行业务的客户 ,此时工程师排查到冷机异常。影响了冷却系统的恢复时长 。随着该可用区受故障影响的主机范围扩大 ,避免出现依赖OSS单AZ和中间件单AZ的问题。启动4台备冷机时因主备共用的水路循环系统气阻导致启动失败 。

阿里云网络少量单可用区产品(如:VPN、无法单台独立启动冷机,

12:30 ,12月18日11:21 ,客户业务开始受到影响,工程师随后继续通过相同方法对其他冷机进行操作  。截至12:30,导致一机房包间温度达到临界值触发消防系统喷淋  ,存储、水盘补水后  ,不辜负客户所托 !将冷机从群控调整为独立运行后,补水排气耗时2小时57分钟,手工修改冷机配置,但操作失败,同时保证手工切换的准确性  ,各网络产品在故障期间保持了业务连续性,

改进措施 :全面检查机房基础设施管控系统,部分Dataworks 、在监控数据采集层面 ,进一步提升云产品高可用容灾逃逸能力  。由于现场冷机处理进展缓慢  ,如果指定了自定义镜像,部署在可用区B 、此次香港Region可用区C服务中断事件 ,

最近关注

友情链接